CLASSEt ROOM IN A BOOK®
The official training workbook from Adobe

Brian Wood
CLASSROOM IN A BOOK®
The official training workbook from Adobe
Brian Wood
CONTENTS

GETTING STARTED

About Classroom in a Book ........................................... 1
Prerequisites ................................................................ 1
Installing the program ................................................... 2
  Minimum system requirements: ................................... 2
Online Content ............................................................. 3
  Lesson Files ............................................................... 3
  Web Edition ............................................................... 3
  Accessing the Lesson Files and Web Edition ............... 3
Recommended lesson order ............................................ 4
Jumpstart ................................................................. 4
Additional resources .................................................... 5
Adobe Authorized Training Centers ............................... 5

1 AN INTRODUCTION TO ADOBE XD CC ................... 6
Introducing Adobe XD CC ............................................ 8
A typical UX design workflow ....................................... 9
Starting Adobe XD and opening a file ......................... 11
  The Home screen ..................................................... 11
Exploring the workspace (macOS) ............................... 12
Exploring the workspace (Windows) ............................ 13
Working in Design mode ............................................. 14
  Getting to know the tools ........................................... 14
  Working with the Property Inspector ......................... 15
  Working with panels ................................................ 16
Prototype mode ....................................................... 18
Changing the view of artwork ..................................... 20
  Using view commands ............................................. 21
datisnetwork.com

datisnetwork.com
Using the Zoom tool ........................................ 22
Scrolling through a document .............................. 24
Navigating artboards ...................................... 25
Previewing your designs .................................. 28
Sharing your designs .................................... 29
Finding resources for using Adobe XD ............... 30

2 SETTING UP A PROJECT ................................................. 32
Starting the lesson ........................................ 34
Creating and saving a new document ................. 35
	Working with cloud documents ...................... 37
Creating and editing artboards ....................... 38
	Creating artboards with the Artboard tool .......... 38
	Editing artboards ........................................ 41
	Changing artboard appearance ...................... 44
	Working with multiple artboards ................. 45
Aligning artboards ..................................... 46
Adding grids to artboards .............................. 47
	Working with square grids ......................... 48
Applying a layout grid ................................ 51
Managing artboards with the Layers panel ......... 53

3 CREATING AND IMPORTING GRAPHICS ..................... 58
Starting the lesson ........................................ 60
Graphics and Adobe XD ................................ 61
Creating and editing shapes ......................... 61
	Creating shapes with shape tools ................. 62
	Changing fill and border ............................ 64
	Creating dashed lines .............................. 66
	Working with border options .................. 68
Rounding corners ..................................... 69
Editing shapes ........................................ 72
Combining shapes ..................................... 74
datisnetwork.com
Editing combined shapes ........................................ 76
Aligning content to the pixel grid ................................. 77
Bringing in content from Adobe Illustrator .................. 79
Exporting artwork from Illustrator for Adobe XD .......... 80
Drawing with the Pen tool ........................................ 81
Drawing straight lines ............................................ 81
Drawing curves .................................................... 83
Changing path direction ......................................... 86
Editing artwork with the Pen tool ............................... 88
Copying the cloud icon .......................................... 89
Working with UI Kits ............................................. 90
Downloading the UI kit .......................................... 90
Opening and copying from the UI Kit ......................... 91

4 ADDING IMAGES AND TEXT ......................................... 94
Starting the lesson ............................................... 96
Assets and Adobe XD ............................................. 96
  Importing an image ........................................... 97
  Importing multiple assets .................................... 99
  Importing assets via drag and drop ......................... 100
  Replacing an image .......................................... 101
  Transforming images ......................................... 102
  Resizing an image in its frame .............................. 104
Bringing in content from Photoshop ......................... 106
  Copying and pasting from Photoshop to XD .............. 106
  Opening a Photoshop file in Adobe XD .................. 108
Masking content .................................................. 111
  Masking with a shape or path .............................. 111
  Editing a mask ................................................. 112
  Masking with an image fill ................................ 115
  Editing an image fill mask ................................. 116
Working with text ............................................... 118
  Adding text at a point ...................................... 118
  Creating a text area ........................................ 119

datisnetwork.com
## 5 ORGANIZING CONTENT

<table>
<thead>
<tr>
<th>Lesson</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Starting the lesson</td>
<td>130</td>
</tr>
<tr>
<td>Arranging objects</td>
<td>131</td>
</tr>
<tr>
<td>Working with the Layers panel</td>
<td>133</td>
</tr>
<tr>
<td>Reordering artboards and layer content</td>
<td>133</td>
</tr>
<tr>
<td>Selecting content using the Layers panel</td>
<td>135</td>
</tr>
<tr>
<td>Locking and hiding content</td>
<td>137</td>
</tr>
<tr>
<td>Searching and filtering in the Layers panel</td>
<td>139</td>
</tr>
<tr>
<td>Working with groups</td>
<td>141</td>
</tr>
<tr>
<td>Creating a group</td>
<td>141</td>
</tr>
<tr>
<td>Editing content within a group</td>
<td>143</td>
</tr>
<tr>
<td>Aligning content</td>
<td>144</td>
</tr>
<tr>
<td>Aligning objects to the artboard</td>
<td>144</td>
</tr>
<tr>
<td>Setting up the icons for alignment</td>
<td>144</td>
</tr>
<tr>
<td>Aligning objects to each other</td>
<td>147</td>
</tr>
<tr>
<td>Distributing the icons</td>
<td>148</td>
</tr>
<tr>
<td>Positioning objects</td>
<td>151</td>
</tr>
<tr>
<td>Aligning with temporary guides</td>
<td>151</td>
</tr>
<tr>
<td>Setting gap distances</td>
<td>152</td>
</tr>
<tr>
<td>Viewing distances with temporary guides</td>
<td>155</td>
</tr>
<tr>
<td>Fixed positioning</td>
<td>156</td>
</tr>
</tbody>
</table>

## 6 WORKING WITH ASSETS AND CC LIBRARIES

<table>
<thead>
<tr>
<th>Lesson</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Starting the lesson</td>
<td>162</td>
</tr>
<tr>
<td>Managing assets with the Assets panel</td>
<td>163</td>
</tr>
<tr>
<td>Saving colors</td>
<td>163</td>
</tr>
<tr>
<td>Editing saved colors</td>
<td>165</td>
</tr>
<tr>
<td>Saving character styles</td>
<td>166</td>
</tr>
<tr>
<td>Editing character styles</td>
<td>169</td>
</tr>
<tr>
<td>Creating symbols</td>
<td>170</td>
</tr>
<tr>
<td>Editing symbols</td>
<td>171</td>
</tr>
</tbody>
</table>

[datisnetwork.com](http://datisnetwork.com)
# CONTENTS

Breaking the link to a symbol ........................................ 173
Linked symbols ......................................................... 176
Updating linked symbols ............................................. 178
Overriding linked symbols ......................................... 180
Breaking the link to a symbol ..................................... 181
Fixing missing linked symbols .................................. 182
Replacing symbols ................................................... 183
Making the footer a symbol ....................................... 186

Working with Creative Cloud Libraries .......................... 187
Adding Photoshop assets to CC Libraries ....................... 187
Adding Illustrator assets to CC Libraries ....................... 189
Using CC Library character styles ............................. 190
Using graphics from a CC Library ............................... 191
Editing library items .................................................. 193

7 USING EFFECTS, REPEAT GRIDS, AND RESPONSIVE RESIZE 196

Starting the lesson ................................................... 198
Applying and editing gradients .................................... 199
  Applying gradients ................................................. 199
  Editing gradient colors ......................................... 202
  Adjusting the direction and length of a gradient ........ 203
Understanding effects ............................................. 205
  Working with background blur ............................... 205
  Working with object blur .................................... 206
  Applying a drop shadow ........................................ 208
Using repeat grids .................................................. 210
  Adding content for a repeat grid ............................ 210
  Creating a repeat grid ......................................... 211
  Editing content in a repeat grid ............................ 213
  Editing content appearance in a repeat grid ............ 217
Adding content to a repeat grid ................................ 217
Finishing the repeat grid .......................................... 219
Responsive resize ................................................... 222
  Getting started with responsive resize ..................... 222
  Grouping content ................................................ 224
Setting manual constraints ........................................ 225
Finishing the design ............................................. 229

8 CREATING A PROTOTYPE ........................................ 232
Starting the lesson .................................................. 234
Starting with prototypes ......................................... 235
  Design mode vs. Prototype mode ............................. 236
  Setting the home screen ....................................... 237
  Linking artboards .............................................. 238
  Previewing links locally ....................................... 240
  Editing links .................................................... 241
  Copying and pasting connections ......................... 244
Taking prototypes further ....................................... 247
  Auto-animating content ...................................... 247
  Auto-animate examples ....................................... 249
  Adding a drag trigger ........................................ 249
  Setting up content for preserving scroll position ...... 251
  Preserving scroll position .................................. 253
  Setting up timed transition content ..................... 255
  Setting timed transitions ................................... 256
  Setting up content for overlays ......................... 259
  Creating overlays ............................................ 261
  Adding a voice trigger ...................................... 262
  Animating the record button ................................ 265
  Adding speech playback ..................................... 265

9 PREVIEWING A PROTOTYPE ....................................... 268
Starting the lesson ................................................ 270
Recording a prototype .......................................... 271
  Recording on macOS .......................................... 271
  Recording on Windows ....................................... 272
Previewing on a device ......................................... 275
  Setting up ..................................................... 275
  Previewing via USB .......................................... 276
  Previewing cloud documents ................................. 281
datisnetwork.com
10 SHARING DOCUMENTS, PROTOTYPES, AND DESIGN SPECS

Starting the lesson .................................................. 288
Methods of sharing .................................................... 289
  Sharing a cloud document ...................................... 289
  Sharing a prototype for review ................................. 293
  Updating a shared prototype ................................. 297
  Commenting on a shared prototype ......................... 300
  Pinning comments .............................................. 303
  Working with comments ...................................... 305
  Sharing design specs .......................................... 308
  Inspecting design specs .................................. 312
  Updating design specs .................................... 317
  Managing shared links ...................................... 318

11 EXPORTING AND INTEGRATION

Starting the lesson .................................................. 322
Exporting assets .................................................... 323
  Exporting as PDF ............................................... 324
  Exporting as SVG .............................................. 325
  Exporting as PNG ............................................... 327
  Exporting as JPG ............................................... 332
Using plugins ........................................................ 334
  Installing a plugin ............................................. 334
  Using a plugin ................................................... 336
  Finishing the design .......................................... 338

INDEX ............................................................. 342

datisnetwork.com
Lesson overview

In this lesson, you’ll learn how to do the following:

- Import images.
- Transform images.
- Bring in content from Adobe Illustrator CC.
- Bring in content from Adobe Photoshop CC.
- Mask content.
- Add text.
- Format text.

This lesson takes approximately 45 minutes to complete. Please log in to your account on peachpit.com to download the lesson files for this lesson, or go to the “Getting Started” section at the beginning of this book and follow the instructions under “Accessing the lesson files and Web Edition.”

Your Account page is also where you’ll find any updates to the lessons or to the lesson files. Look on the Lesson & Update Files tab to access the most current content.
In Adobe XD, images and text play an important part in any design. This lesson focuses on importing and transforming images, as well as adding and formatting text.
Starting the lesson

In this lesson, you’ll bring raster images into, and add text to, your app design. To start, you’ll open a final lesson file to get an idea for what you will create in this lesson.

1. Start Adobe XD CC, if it’s not already open.
2. On macOS, choose File > Open From Your Computer. On Windows, click the menu icon (≡) in the upper-left corner of the application window and choose Open From Your Computer.

For either macOS or Windows, if the Home screen is showing with no files open, click Your Computer in the Home screen. Open the file named L4_end.xd, which is in the Lessons > Lesson04 folder that you copied onto your hard disk.

3. If you see a message at the bottom of the application window about missing fonts, you can click the X on the right side of the message to close it.
4. Press Command+0 (macOS) or Ctrl+0 (Windows) to see all of the design content. This file shows you what you will create by the end of the lesson.

5. Leave the file open for reference, or choose File > Close (macOS) or click the X in the upper-right corner of the open window (Windows) to close the file.

Assets and Adobe XD

In the previous lesson, you explored creating, importing, and editing vector graphics. In this lesson, you’ll learn about the different types of image assets you can import into Adobe XD, the different methods for bringing them in from programs like Photoshop and Sketch, and how to work with them to fit your design.

When it comes to images, Adobe XD supports PSD, AI, PNG, GIF, SVG, JPEG, and TIFF images. In Adobe XD, images (both raster and vector) that you import are embedded in the XD file, since there is no image-linking workflow, by default, as you would find in Adobe InDesign.

datisnetwork.com
Sizing raster images for Adobe XD

If you’re designing using the default artboard sizes (1x), you need to pay attention to the sizing of any raster images (JPEG, GIF, PNG) that you import into your design. The sizing is especially important if you will later need to export production-ready assets for a website or app.

It’s best to edit your raster images in a program like Photoshop to be the maximum size you need before you import them into XD. In the case of an image for a website, if your image spans the entire width of a 1920 x 1080 artboard, you’ll want to ensure that your image is 3840 pixels across (twice the width of the intended use in XD). Be careful about simply importing overly large images each time you need an image, since large file sizes can slow down load time.

If you’re designing for iOS, and designing at 1x, you’ll want to make sure that any raster images you import are scaled at 3x (three times the size they are in your Adobe XD design), and for Android, 400% (or 4x).

Importing an image

In Adobe XD, there are several methods for adding assets to your projects. In this section, you’ll import a few assets into your design using the Import command.

1. Choose File > Open From Your Computer (macOS) or click the menu icon (Ξ) in the upper-left corner of the application window and choose Open From Your Computer (Windows). Open the Travel_Design.xd document in the Lessons folder (or where you saved it).

2. Press Command+0 (macOS) or Ctrl+0 (Windows) to see all of the content.

3. With the Select tool (▼) selected, click the Home artboard in the document window.

4. Choose File > Import (macOS) or click the menu icon (Ξ) in the upper-left corner of the application window and choose Import (Windows). Navigate to the Lessons > Lesson04 > images folder. Click to select the image named home_1.jpg. Click Import.

JPEG images you import into Adobe XD are placed at half size. That means a JPEG that is 400 pixels x 400 pixels will be placed at 200 pixels x 200 pixels. The image is placed in the center of the selected artboard and is larger than the artboard. Any image content that is outside the bounds of the artboard is hidden. With the image selected, XD shows the masked content as semi-transparent to give you a preview of what is hidden.

Note: If you are starting from scratch using the jumpstart method described in the section “Getting Started,” open L4_start.xd from the Lessons > Lesson04 folder.

Note: To learn more about image sizing and Adobe XD, see the sidebar “Sizing raster images for Adobe XD.”

datisnetwork.com
5 With the Select tool (\(\text{Select tool}\)) selected, drag the image until the bottom edge snaps to the bottom edge of the artboard, and ensure that it’s still centered on the artboard (a vertical aqua guide will appear when it’s centered).

6 Drag the top-middle handle of the image down until the image is as tall as the artboard.

The proportions of raster images are maintained when resizing by dragging.

7 Right-click the image and choose Send To Back (macOS) or Arrange > Send To Back (Windows) to arrange the image behind the other content on the Home artboard.

8 Click away from the image, in a blank area of the document window, to deselect it. You should now see that the image content that is outside the bounds of the artboard is hidden.

\textbf{Tip:} You can also scale an image non-proportionally if you need. Before dragging to resize, with the image selected, you can turn off the Lock Aspect option (\(\text{Lock Aspect}\)) in the Property Inspector on the right.

\textbf{Note:} If you were to export the home_1.jpg image (not the entire artboard), the final asset would not be cropped as you see it when you deselect the image on the artboard. You’ll learn about exporting in Lesson 11, “Exporting and Integration.”

datisnetwork.com
Importing multiple assets

In Adobe XD, you can import multiple assets using a variety of methods. In this section, you’ll import an SVG file and a PNG using the Import command.

1. Choose File > Import (macOS) or click the menu icon (≡) in the upper-left corner of the application window and choose Import (Windows). Navigate to the Lessons > Lesson04 > images folder. Click to select the image named journal_header.png and Command-click (macOS) or Ctrl-click (Windows) the image named red_map.svg. Click Import.

Both assets are placed next to each other, in a row, in the center of the document window. Any imported assets that touch an artboard are placed on that artboard. If a placed image doesn’t overlap the first artboard, it will be placed on the next artboard to the right, and so on. Images that don’t overlap an artboard will be placed on the empty pasteboard.

2. Drag one of the assets down to drag them both away from the artboards.

3. With the Select tool selected, click in a blank area away from the selected assets to deselect them. Click the red map artwork to select it.

Note: In the images folder, you’ll see an Illustrator document named red_map.ai. You can import native Illustrator documents (.ai) into Adobe XD as well.

Note: If the image seems to disappear, it may have been placed on the iPad sized artboard, and most of it may be hidden. You can drag the image to the left a bit to get it on the Journal artboard.
4 Right-click the selected map artwork and choose Cut. Right-click in the Countdown artboard and choose Paste.

5 Drag the other image you placed, journal_header.png, from its center, into the middle of the Journal artboard. Make sure the pointer is within the bounds of the Journal artboard and release the mouse button.

The image is placed on the Journal artboard and is cropped by the bounds of the artboard.

**Importing assets via drag and drop**

Another method for bringing assets into Adobe XD is to drag and drop from the Finder (macOS) or File Explorer (Windows). This is a great way to insert images into existing frames (as you’ll see in a later section, “Masking with an image fill”) or as a more precise placement option.

1 With the Select tool (▼) selected, click in a blank area away from the artboards to deselect all.
2 Go to the Finder (macOS) or File Explorer (Windows), open the Lessons > Lesson04 > images folder, and leave the folder open. Go back to XD. With XD and the folder showing, click the image named scene_1.png.

3 Command-click (macOS) or Ctrl-click (Windows) the image named scene_2.png to select both images. Release the key and drag either of the selected images into XD, just below the Home artboard.

Both images are placed next to each other on the pasteboard as a row of images. If you were to release the mouse button over an artboard, any images that touch the artboard would be placed on that artboard. Images that don’t overlap an artboard will be placed on the empty pasteboard.

4 Click in Adobe XD to make it the focus again, if necessary.

Replacing an image

If you need to replace an image in your design, you can do so by dragging an image from your desktop onto an existing image to replace it. Next, you’ll replace a copy of an image in your design.

1 Go to the Finder (macOS) or Windows Explorer (Windows), open the Lessons > Lesson04 > images folder, and leave the folder open in the Finder window (macOS) or Windows Explorer (Windows). Go back to XD.
2 With XD and the folder showing, click the image named home_2.jpg. Drag the image on top of the home_1.jpg image on the Home artboard. When it shows a blue highlight, release the mouse button to replace the image.

The image will fill the shape proportionally and will most likely be masked by the shape (parts of the new image may be hidden). This may mean that the new image is scaled if the image you are replacing is larger or smaller than the image you are dragging in.

3 With the image on the Home artboard selected, press Command+C (macOS) or Ctrl+C (Windows) to copy it. With the Select tool selected, click in a blank area of the Hike Detail artboard to make it the active artboard. Press Command+V (macOS) or Ctrl+V (Windows) to paste it.

Content copied from one artboard to another is pasted in the same position, relative to the upper-left corner. In Lesson 5, “Organizing Content,” you’ll see how to arrange content and work with layering to get the new image behind the content you pasted from the iOS UI kit in Lesson 3, “Creating and Importing Graphics.”

### Transforming images

Images you import into Adobe XD can be transformed in a variety of ways—from scaling and rounding corners to rotating and positioning. In this section, you’ll apply a few transformations to the images you’ve imported so far.

1 Click the image on the Journal artboard.

2 Press Command+3 (macOS) or Ctrl+3 (Windows) to zoom in to the selection.
3 Press Command and – (macOS) or Ctrl and – (Windows) once to zoom out. Notice the corner widgets (◯) in the corners of the image. As with vector shapes you draw, you can also round the corners on an image or in the Property Inspector. For more information on rounding corners, refer to the Lesson 3 section “Rounding corners.”

4 Drag the image to reposition it. Notice that as you drag, if an edge of the image comes close to an artboard edge, it snaps. As you drag, press the Command (macOS) or Ctrl (Windows) key to temporarily turn off snapping. Position the image as you see in the following figure. Release the mouse button and then the key.

5 Drag the lower-left bounding point of the box around the image up and to the right to make it smaller. Make sure it’s still a little wider than the artboard. With the image in place, next you’ll transform another by scaling and rotating.

6 Zoom out, using any method, far enough to see the Recording artboard.

7 Drag across the topographic map artwork on the Recording artboard to select all of it. Move the pointer just off any corner of the selected artwork. When the rotate arrow (↩) appears, drag counterclockwise to rotate the artwork. When you see approximately −10° in the rotation angle of the Property Inspector, release the mouse button.

Note: If the image doesn’t scale in proportion, make sure the Lock Aspect (locked) option is selected in the Property Inspector and try scaling it again.

Tip: Pressing the Shift key as you drag to rotate will constrain the rotation to 15 degree increments.
As you rotate, the Rotation value will change in the Property Inspector. You can also edit the Rotation value in the Property Inspector to rotate an object.

8 Shift-drag the lower-right corner away from the center to make it larger, ensuring that the artwork covers the bottom part of the artboard. Release the mouse button and then the key.

9 Press Command+0 (macOS) or Ctrl+0 (Windows) to see everything.

10 Click the image at the top of the Journal artboard to select it. Change the X value to 0 and press Return or Enter. Leave the Y value (vertical position) as is in the Property Inspector. Leave the image selected.

The X (horizontal) value and Y (vertical) value each start at zero (0) in the upper-left corner of each artboard. Content such as the image, in this case, is positioned from its upper-left corner relative to the upper-left corner of the artboard. Positioning content using the X and Y values can help you work more precisely.

**Resizing an image in its frame**

Images you bring into XD are contained within a frame. When you transform an image frame, the image is transformed as well. You can also select the image within the frame and transform it separately. Next, you'll resize an image within its frame. This can be an easy way to hide parts of an image you don't want showing.

1 With the image at the top of the Journal artboard still selected, zoom in to the selected image by pressing Command+3 (macOS) or Ctrl+3 (Windows) or by using any other method you have learned so far.
2 Double-click the image to reveal bounding points around it.

The points you see around the perimeter of the image are used to resize the image within the frame. Currently you can’t edit the individual anchor points for the shape of the image frame. The corner radius widgets that you saw previously in the image corners are now gone. When you edit the image within the frame, you can no longer edit the corner radius of the corners.

Later in this lesson, you’ll learn about masking an image with a shape. In that case, you will be able to edit the frame or the image within the frame.

3 Drag the bottom-middle point of the image down to make it larger within the frame.

The bottom part of the image will be hidden when you drag beyond the edge of the frame it’s in.

4 Press the Esc key to stop resizing the image and show the bounding box of the image again.

5 Drag the lower-right point of the bounding box toward the center of the image to make it a bit smaller. Make sure it still covers the width of the artboard.

6 Press Command+0 (macOS) or Ctrl+0 (Windows) to see everything.

7 Choose File > Save (macOS) or click the menu icon (Ξ) in the upper-left corner of the application window and choose Save (Windows).
Bringing in content from Photoshop

There are a lot of ways to bring content from Photoshop into XD: copy and paste, export from Photoshop and import into XD, import a Photoshop file (.psd) (which places the PSD content into the XD file), open a Photoshop file (.psd) directly in XD (which opens the PSD as a separate XD file), or place the content in a Creative Cloud Library and drag it into your design from the Creative Cloud Library panel in XD.

In this section, you’ll use a few different methods to bring content from Photoshop into your design in Adobe XD.

Copying and pasting from Photoshop to XD

To start, you’ll open a Photoshop document in Photoshop and copy content that you will then paste into your Adobe XD project.

1. Open the latest version of Adobe Photoshop CC.

2. Choose File > Open. Navigate to the Lessons > Lesson04 > images folder, select the file named journal.psd, and click Open. If the New Library From Document dialog box appears, click Cancel.

The Photoshop file contains a design with multiple artboards that contains layers of imagery, text, vector content, and more. Next, you’ll copy image content and paste it into Adobe XD as a flattened raster image.

3. Choose View > Fit On Screen.

The image at the top of the Journal artboard needs to be copied into your XD project, without the time and other status bar information currently on top of it. You can make a selection, select specific layers, and copy what you need or simply copy a selected area and paste a flattened raster image of that content.

datisnetwork.com
4 Make sure the Layers panel is open. You can choose Window > Layers to see it. In Photoshop, the Layers panel lists artboards along with layers. They’re marked by disclosure triangles, as groups are, but they lack the folder icons that groups display.

5 Click the disclosure triangle next to the Journal artboard name (it should be at the top of the list) to reveal the contents of the artboard. Scroll down in the Layers panel, if necessary, to see the layer named Journal Header Image. Click to select it.

6 Command-click (macOS) or Ctrl-click (Windows) the layer thumbnail to the left of the layer name in the panel to make a selection from the layer content.

7 Choose Edit > Copy to copy the image within the selection marquee.

8 Close Photoshop, without saving if asked. Back in Adobe XD, in the Travel_Design document, press Command+0 (macOS) or Ctrl+0 (Windows) to see all of the artboards, if you don’t already.

9 With the Select tool selected, click in the gray pasteboard away from the artboards to deselect all.

10 With nothing selected, press Command+V (macOS) or Ctrl+V (Windows) to paste the content into the center of the document window.

11 Drag the image below the Icons artboard.

12 Choose File > Save (macOS) or click the menu icon (≡) in the upper-left corner of the application window and choose Save (Windows).
Opening a Photoshop file in Adobe XD

You can open Photoshop (.psd) files in Adobe XD, and they will be converted into XD files. When a Photoshop file is opened in XD, Photoshop elements and effects that can be mapped to XD’s functionality are available. The rest of the elements either are rasterized or don’t appear in the XD file. Next, in Adobe XD you’ll open a design started in Photoshop.

1. In Adobe XD, choose File > Open From Your Computer (macOS) or click the menu icon (≡) in the upper-left corner of the application window and choose Open From Your Computer (Windows). Open the journal.psd document in the Lessons > Lesson04 > images folder.

The Photoshop document is now an XD document called Journal, that is open in Adobe XD.

2. Press Command+0 (macOS) or Ctrl+0 (Windows) to see all of the content. Most of the content on the two artboards is still editable in XD, but there are a few exceptions. For a listing of the supported features when you open Photoshop files in Adobe XD, see https://helpx.adobe.com/xd/kb/open-photoshop-files-in-xd.html.

3. With the Select tool ( ▼) selected, click the text “Meng” in the Journal artboard.

4. Open the Layers panel by clicking the Layers panel button ( ₹) in the lower-left corner of the application window, if it isn’t already open. In the Layers panel, you’ll see a folder icon ( ▲) to the left of the selected content named “Hike info,” which indicates a group of content. Click the folder icon to reveal everything in it. All of the text is still editable.

datisnetwork.com
5 Click the white status bar content at the top of the Journal artboard on the left. The status bar content has been rasterized and is now a single image. You can tell because of the image icon (רס) in the Layers panel to the left of the name. Next, you'll copy one of the artboards into your project.

6 Click in a blank area, away from the artboards, to deselect all. Then click the Journal ver2 artboard name above the artboard on the right. Press Command+C (macOS) or Ctrl+C (Windows) to copy the artboard and all of its content.

7 Choose File > Close (macOS) or click the X in the upper-right corner (Windows) to close the Journal document, without saving it.

8 Back in the Travel_Design.xd document, press Command+V (macOS) or Ctrl+V (Windows) to paste the artboard and content to the right of the iPad artboard.
9 Drag the group with the “Meng” text to the Journal artboard and drop it below the image.

10 To center the content on the Journal artboard, click the Align Center (Horizontally) button (尴) at the top of the Property Inspector. The group is aligned to the horizontal center of the artboard.

Note: You can only open Sketch files created using Sketch version 43 or newer. If you have an older file, save the file using the latest version of Sketch, and then open the file in XD.

Tip: You can drag images directly from all modern web browsers onto your artboards. You can also drag the images into an object on an artboard; when you do so, the image size is automatically adjusted to fit the object.

---

**Bringing in assets from Sketch**

You can open a .sketch file directly in XD. You can then edit the file in XD just like any other XD file, wire interactions, and share as prototypes or design specs.

- You can also select an asset in Sketch, make it exportable as SVG, and drag the content from the Layers panel into XD.
- You can also copy a Sketch file to the OS clipboard, and use the Paste Appearance option to paste the image directly as an image fill.

—From XD Help
Masking content

You can easily hide portions of images or shapes (paths) using two different methods of masking in Adobe XD: mask with shape or image fill. Masks are nondestructive, which means that nothing that is hidden by the mask is deleted. In either case, you can adjust the mask, if required, to highlight another portion of the masked content.

Masking with a shape or path

The first method for masking you will learn is masking with a shape. This method of masking (hiding) portions of artwork or images is similar to masking in a program like Illustrator. The mask is either a closed path (shape) or an open path (like a path in the shape of an “s,” for instance). To mask content, the masking object is on top of the object to be masked. Next, you’ll mask a portion of artwork.

1. Click in the gray pasteboard area to deselect all.
2. In the Layers panel on the left, double-click the artboard icon (■) to the left of the Recording artboard to select it and zoom in to it.
3. Click to select the map illustration artwork so you can see all of it.
4. Select the Rectangle tool (■) in the toolbar. Starting at the top edge of the artwork on the left edge of the artboard, drag down and to the right corner of the artboard.

   ![Rectangle tool demonstration]

5. Press the V key to select the Select tool.
6. With the shape still selected, in the Layers panel, Shift-click the Path and Group objects to select the map artwork behind the shape.

   ![Select tool demonstration]

Tip: Pressing the R key will select the Rectangle tool.
7 Choose Object > Mask With Shape (macOS) or right-click and choose Mask With Shape from the menu that appears (Windows).

With the Layers panel open and the image still selected on the artboard, you’ll see Mask Group 1 in the Layers panel list. The mask shape and the object that is masked are now part of a group.

**Editing a mask**

When you mask content, you may later want to crop it in a different way, revealing more or less of that content. When you mask with a shape, as you did in the previous section, you can easily edit both the mask and the object masked. Next, you’ll change how the content from the previous section is masked.

1 With the Select tool (▶️) selected and the image still selected, double-click the map artwork to enter mask editing mode. The mask (rectangle) will be selected.

Double-clicking a masked object will temporarily show the mask and the masked object (the map artwork, in this instance) in the window. That way, you can edit either the mask or the object that is masked.
2 Click the Different Radius For Each Corner button ( ) in the Property Inspector on the right. Change the first two values to 15, pressing Return or Enter after typing in the second value. Leave the last two values at 0.

The top two corners of the mask are now slightly rounded. If you wanted to edit the mask shape further, you could double-click the edge of the mask and enter Path Editing mode to edit the anchor points.

3 In the Layers panel, click the Mask Group 1 icon ( ) to reveal the content of the mask group, if you don’t already see it. Click the “path” object and then Shift-click the “group” object to select both. To keep them together, you will now group them. Right-click one of the selected objects in the Layers panel list and choose Group to group them.

---

**Note:** Any appearance property changes you make to the rectangle shape that is the mask, like fill or border, will not show when you exit the editing mode.

**Tip:** In Path Edit mode, you can add, delete, and move anchor points as well as convert them between smooth and corner (and back) by double-clicking.

**Note:** The numbers you see in the names of objects in the Layers panel (“Path 154,” for example) may be different, and that’s okay.
4 Option+Shift-drag (macOS) or Alt+Shift-drag (Windows) the lower-right handle of the map artwork down a little to make it larger.

You could transform the masked content in different ways, or you could select the shape that is the mask (the rectangle, in this case) and reposition or resize it. You can also copy and paste other content into the mask.

5 Drag the selected artwork into the center of the artboard. Make sure that it fills the mask shape and covers the lower corners of the artboard.

Tip: You can also stop editing the parts of a mask by clicking other artwork in the document.

Tip: To remove a mask, you could select the mask group and choose Object > Ungroup Mask (macOS) or right-click the group and choose Ungroup Mask (Windows). You can also press Shift+Command+G (macOS) or Shift+Ctrl+G (Windows).

6 Press the Esc key to exit the mask editing mode. The map artwork is once again masked.

Note: Masked content is cropped like you see on the artboard when the asset is exported. You’ll learn about exporting in Lesson 11.

7 Press Command+0 (macOS) or Ctrl+0 (Windows) to see everything.

8 Click in a blank area away from the artboards to deselect the masked content.

9 Choose File > Save (macOS) or click the menu icon in the upper-left corner of the application window and choose Save (Windows).

Tip: To remove the parts of a mask by clicking other artwork in the document.

Tip: To remove a mask, you could select the mask group and choose Object > Ungroup Mask (macOS) or right-click the group and choose Ungroup Mask (Windows). You can also press Shift+Command+G (macOS) or Shift+Ctrl+G (Windows).
Masking with an image fill

Another method for masking is to drag and drop an image into an existing shape or path. The image becomes the fill of the shape. This method of masking is great when adding design content to a low-fidelity wireframe, for instance. Next, you’ll import a new image for a profile picture and mask it with a shape.

1. Double-click the artboard icon (Rectangle) to the left of the artboard name “Journal” in the Layers panel to fit the artboard in the document window.

2. Select the Ellipse tool (Ellipse) in the toolbar. Shift-drag on the Journal artboard to create a circle. Release the mouse button and then the key when you see a width and height of approximately 144 in the Property Inspector. As you drag, you’ll notice that the Width and Height values change by 8 because the circle is snapping to the square grid.

3. Go to the Finder (macOS) or File Explorer (Windows), open the Lessons > Lesson04 > images folder, and leave the folder open. Go back to XD. With XD and the folder showing, find the image named meng.png in the folder, and drag the image on top of the circle you drew in the Journal artboard. When the circle is highlighted in blue, release the mouse button to drop the image into the frame.

Tip: If the circle doesn’t have a width and height of exactly 144, you could set the Lock Aspect option (Lock) in the Property Inspector and change either Width or Height to 144 to change both together.

Note: If you were to deselect the Fill option in the Property Inspector with the shape selected, the image would be hidden. Also, if you change the fill color for the shape in the Property Inspector, the image will be removed from the shape.

By dragging an image onto a shape, the image becomes the fill of the shape.

datisnetwork.com
Editing an image fill mask

Dropping an image into a shape so that it becomes the fill of the shape means the image is always centered in the shape. Next, you’ll explore the editing capabilities of this type of mask.

1. With the Select tool (▼) selected, double-click the image to enter Path Edit mode. The image will be selected.

2. Drag a corner of the image to make it larger. Then, drag the image so that more of her face is in the circle.

3. Press the Esc key to stop editing the image within the circle.

4. Deselect the Border option in the Property Inspector to turn it off.

5. With the masked image still selected, Shift-drag a corner of the bounding box to make the image smaller. When Width and Height are 80 in the Property Inspector, release the mouse button and then the key.
The image will remain centered in the shape and resizes proportionally to fill the shape. Unlike images you place, the Lock Aspect option is not selected for masked content by default. That’s why you held the Shift key down when resizing it.

6 Drag the image into position, as you see in the figure.

7 Choose File > Save (macOS) or click the menu icon in the upper-left corner of the application window and choose Save (Windows).

**Note:** The Width and Height values may change by different values in the Property Inspector, depending on the zoom level of the document. If you are zoomed out far enough, the width and height will change by 8.

**Tip:** If the circle doesn’t have a width and height of exactly 80, that’s okay. You could set the Lock Aspect option in the Property Inspector and change either Width or Height to 80 to change both together.
When adding text to your design in Adobe XD, you have two main methods to choose from: adding it at a point or in an area. Text at a point is a horizontal line of text that begins where you click and expands as you enter characters. Each line of text is independent—the line expands or shrinks as you edit it but doesn’t wrap to the next line unless you add a paragraph return or a soft return. Entering text this way is useful for adding a headline or a few words to your artwork.

Text in an area uses the boundaries of an object to control the flow of characters. When text reaches a boundary, it automatically wraps to fit inside the defined area. Entering text in this way is useful when you want to create one or more paragraphs. In this section, you’ll explore the different ways to create text and change the formatting of text.

Adding text at a point

With some design content on the Home artboard in place, next you’ll focus on adding text to it. Since this new text will be a single line, creating text at a point is the best option, as you’ll soon see.

1. Press Command+0 (macOS) or Ctrl+0 (Windows) to see all of the content.
2. Click in a blank area away from the artboards to deselect everything. Double-click the artboard icon (□) to the left of the Home artboard to zoom in to it and select the artboard.
3. To temporarily turn off the square grid, in the Property Inspector, deselect the Square grid option.
4. Select the Text tool (T) in the toolbar. Click to the left of the Home artboard and type field. If you see an auto-correct menu below the text that shows the text “Field,” click the X to the right to keep the lowercase “field.”
5. Press Return or Enter, and type guide to create text at a point. Once again, to keep the text lowercase, you may need to click the X to the right of the auto-correct menu that appears beneath the text.
If you continue to type, the text will continue to the right until you either press Return/Enter for a paragraph return or press Shift+Return (macOS) or Shift+Enter (Windows) for a soft return.

6 Press Esc to select the text object.

A single point appears at the bottom of the bounding box around the text. This is one way to tell that this is text at a point.

7 Drag the point at the bottom of the text object down and up to see the font size change. Stop dragging when you see a font size of approximately 100 in the Property Inspector.

8 With the text object still selected, click the Fill color box in the Property Inspector. Change the color to white in the Color Picker that appears.

9 Select the Select tool (►) and drag the text into the center of the Home artboard.

10 Choose File > Save (macOS) or click the menu icon (≡) in the upper-left corner of the application window and choose Save (Windows).

Creating a text area

To create text in an area, you drag with the Text tool (T). Doing that creates an area to type text into. After you draw the text area, the cursor appears, and you can type. Next, you’ll create a text area for body copy that you’ll add to your design.

1 Press the spacebar to access the Hand tool ( mano), and drag in the document window to see the Hike Detail artboard to the right of the Home artboard. You can also drag on a trackpad with two fingers to pan in the document window.

datisnetwork.com
2 Select the Text tool (T) in the toolbar, and over the bottom half of the image, drag from the left edge of the artboard to the right edge to create a text area that is as wide as the artboard. Type Pine Meadow Lake Loop (without a period).

You may notice that your text doesn’t fit within the text area (but you see it all) since the formatting is the same as the last text and is rather large. Also, the text is wrapping within the bounds of the text object.

3 Select the Select tool (v) and notice the very small dot in the bottom-middle point of the box around the text. That dot indicates that there is overset text, or the text doesn’t fit.

To make all of the text visible, you could drag the bottom-middle point down until it all shows. Since the text is so large, in this case, you will simply change the font size.

4 Double-click the text to select it. You should now see all of the highlighted text.

5 Select the Font Size value in the Property Inspector and type 36. Press Return or Enter to accept the change. Make sure the text color is white.

6 Press the Esc key to select the text object again and not the text within.

datisnetwork.com
Importing text

Next, you’ll add more text to the design from a text file. This can be a great method for adding text to your designs from an external source.

1. Press Command+0 (macOS) or Ctrl+0 (Windows) to see all of the content.

2. Choose File > Import (macOS) or click the menu icon (≡) in the upper-left corner of the application window and choose Import (Windows). Navigate to the Lessons > Lesson04 folder and select the file named Hiking.txt. Click Import to place the text in its own type object on the same artboard.

3. Select the Select tool (Selector) and drag the text you just placed down toward the bottom of the artboard.

   You may need to zoom out a little to see the bottom part of the artboard or pan using the Hand tool (spacebar). You can also drag on a trackpad with two fingers to pan in the document window.

4. Press Command+3 (macOS) or Ctrl+3 (Windows) to zoom in to the text.

5. Drag the text area close to the left edge of the artboard (see the figure). As you drag, you should feel it snapping to the square grid on the artboard. Drag until you see 16 for the X value in the Property Inspector on the right.

6. Drag the middle-right point of the text area to the right to make it wider. Stop dragging when it’s the same grid distance from the right edge of the artboard as it is from the left edge.

   ▶ Tip: You can easily include text in your design by simply dragging a plain text file onto your artboard. This action creates an area text object with the contents of the text file. You can also copy and paste text onto the artboard, creating an area text object that you can easily move and edit in Adobe XD.

   • Note: If you remove all of the text from a text area, the text area itself will also be removed.

7. Click in a blank area of the document window away from content to deselect.
Styling text

In Adobe XD, the text-formatting options are found in the Property Inspector and include formatting such as type (point or area text), font size, text alignment, and more. In this section, you’ll get a feel for formatting text in Adobe XD by applying formatting to text.

1. Double-click the artboard icon (square) to the left of the artboard name “Home” in the Layers panel to fit the Home artboard in the document window.

2. With the Select tool (arrow) selected, click to select the text “field guide.”

3. Make sure that Helvetica Neue (macOS) or Segoe UI (Windows) is selected for the font in the Property Inspector. Click the arrow next to “Regular” to reveal the Font Weight menu, and choose Bold.

For both text at a point and area text, you can change the formatting for all of the text by simply selecting the type object with the Select tool. If you want to apply different formatting to different text within text at a point or a text area, you can select text with the Text tool.

4. To adjust the space between the lines of text, change Line Spacing (tablet) to 96 in the Property Inspector. Press Return or Enter.

Line spacing is the space between lines of text and is similar to leading in programs like Adobe Illustrator.

5. Press the spacebar to access the Hand tool (hand), and drag in the document window to see the text on the Hike Detail artboard. You can also drag on a trackpad with two fingers to pan in the document window.
6 With the Select tool (▼) selected, click the text “Pine Meadow Lake Loop.” Make sure Font Size is 36 and Font Weight is Bold in the Property Inspector. Change Line Spacing to 40. Press Return or Enter after the last value entered.

![Image of text selection and styling](image1.png)

7 Drag the right-middle point of the text area to the left so the text wraps like it does in the figure.

8 Drag the bottom-middle bounding point up to just below the text.

This is meant to make the frames as small as they can be so that it will be easier to select a lot of content in a small area.

9 Drag the text to the right so that the X value in the Property Inspector is 16.

![Image of text movement](image2.png)

10 With the Select tool (▼) selected, click in the gray pasteboard to deselect.

11 Select the Text tool (Arial), and click below the Pine Meadow Lake Loop text. Type DISTANCE, press Return or Enter, and type 3.6 mi.

![Image of text typing and styling](image3.png)

12 Press Command+A (macOS) or Ctrl+A (Windows) to select all of that text. In the Property Inspector, change the font size to 10 and the line spacing to 16.

![Image of property inspector settings](image4.png)

Tip: To change values in fields, you can select the value and press the up or down arrow keys. If you press the Shift+up or down arrow keys, the value changes by 10.
13 Double-click the text DISTANCE to select it. Change the character spacing to 100 and press Return or Enter.

I zoomed in to the text to more easily see it.

14 Drag across the 3.6 mi text to select it. Change the font size to 16. Press Return or Enter. Press the Esc key to select the text area.

**Duplicating text**

One way to reuse text formatting is to copy a text object that has the formatting you want and change the text. You can also click in text with formatting you want and then create a new text object and use the formatting from the original text. In this final section, you'll copy text and change it.

1 With the Select tool (منذ) selected, drag the DISTANCE text object so its left edge aligns with the Pine Meadow Lake Loop text above it. See the first part of the following figure for the position.

2 Option-drag (macOS) or Alt-drag (Windows) the DISTANCE text object straight to the right. When horizontal alignment guides appear, indicating the copy is aligned with the original, release the mouse button and then the key.

3 Select the Text tool and double-click in the *copied* DISTANCE text to select it, and type **DURATION** to replace the text. Double-click in the *copied* 3.6 mi text to select it, and type **3:15 hr** to replace the text.

[Image of text manipulation steps]

[Image of text after modification]

[datisnetwork.com]
4 Press Esc to select the text object. Select the Select tool (.), and Option-drag (macOS) or Alt-drag (Windows) the DURATION text object straight to the right. This time, you may see a gap value and a pink bar appear between all three text objects when the gap is the same value. Release the mouse button and then the key.

You may not see the gap values because the text is snapping to the square grid. If, when dragging, you don’t see the gap values, you can either zoom in further or turn off the square grid for the artboard and try dragging again. To turn off the square grid for the artboard, press Command+’ (macOS) or Ctrl+’ (Windows). After dragging, you can then turn the grid back on by pressing the same keyboard shortcut.

5 Change the text to ELEVATION 384 ft (see the figure).

6 Repeat the last two steps to create another copy. Change the text to DIFFICULTY HARD (see the figure).

7 Press Command+0 (macOS) or Ctrl+0 (Windows) to see all of the artboards.
8 Click in a blank area of the document window away from content to deselect.

9 Choose File > Save (macOS) or click the menu icon (≡) in the upper-left corner of the application window and choose Save (Windows).

10 If you plan on jumping to the next lesson, you can leave the Travel_Design.xd file open. Otherwise, choose File > Close (macOS) or click the X in the upper-right corner (Windows) for each open document.

---

**Spelling and grammar in XD**

In Adobe XD, by default, spelling check and grammar check are enabled. You can access Spelling and Grammar by choosing it from the Edit menu (macOS) or by clicking the menu icon (≡) in the upper-left corner of the application window (Windows).

With Spelling and Grammar enabled, and the cursor in text or text selected, if a word is miss-spelled, it will have the red underline. You can right-click the word and choose from alternatives.

With Spelling and Grammar enabled, XD will also auto-correct text you are typing. If you mis-type a common word, the suggested correction may appear below the word (see the first part of the following figure). You can click the correction to apply it. If you continue typing another word or punctuation, for instance, the word will be auto-corrected (see the second part of the following figure).
Review questions

1. What are at least three asset types you can import into Adobe XD?
2. Briefly, how do you temporarily disable snapping when dragging an image?
3. How do you replace an image?
4. What are the two methods for masking?
5. What are at least two methods for bringing Photoshop content into Adobe XD?
6. What is the difference between text at a point and area text?

Review answers

1. The types of asset files you can import into Adobe XD are PSD, AI, Sketch, SVG, GIF, JPEG, PNG, and TIFF.
2. When dragging an image, you can press the Command (macOS) or Ctrl (Windows) key to temporarily disable snapping.
3. You can drag an image from your desktop onto an existing image to replace it.
4. In Adobe XD, you can easily hide portions of images or shapes (paths) using two different methods: mask with shape or image fill. Masks are nondestructive, which means that nothing that is hidden by the mask is deleted.
5. There are several ways to bring content from Photoshop into Adobe XD: copy and paste, export from Photoshop and import into XD, import a Photoshop file (.PSD) (which places the .PSD content into the XD file), open a Photoshop file (.PSD) directly in XD (which opens the .PSD as a separate XD file), or place the content in a Creative Cloud Library and drag it into your design from the Creative Cloud Library panel in XD.
6. Text at a point begins where you click and expands as you enter characters. Each line of text is independent—the line expands or shrinks as you edit it but doesn’t wrap to the next line unless you add a paragraph return or a soft return. Text in an area uses the boundaries of an object to control the flow of characters. When text reaches a boundary, it automatically wraps to fit inside the defined area.
### INDEX

**A**
- action setting, 239
- Adobe After Effects, 333
- Adobe Authorized Training Centers, 5
- Adobe Create Magazine, 5
- Adobe forums, 5
- Adobe ID, 187, 275, 309
- Adobe XD
  - described, 8, 31
  - image formats, 96
  - installing, 2
  - mobile app, 275–276
  - plugins, 334–340
  - resources, 5, 30
  - starting work in, 11
  - system requirements, 2
  - third-party integration, 340
  - unit-less nature of, 49
  - workspace, 12–13
- Adobe XD Learn & Support page, 5, 30
- Adobe XD product home page, 5
- After Effects projects, 333
- Align Center button, 110

**aligning**
- artboards, 46, 150
- content to pixel grid, 77–78
- guides used for, 62, 82, 151
- objects to artboard, 144
- objects to each other, 147–148
- setting up icons for, 144–147

**anchor points**
- creating, 82
- editing, 72, 75
- paths and, 83

**Android**
- exporting PNG files for, 330
- measurement units for, 310
- resolution settings for, 311

**animation**
- auto-animating content, 247–249
- connection setting for, 239
- of record button, 265

**appearance changes**
- artboard, 44–45
- repeat grid, 217
- shape, 64–65

**application modes**, 12, 13

**area text**, 118, 119–120, 127

**arranging**
- artboards, 42–43
- objects, 131–132
- Artboard tool, 38–41, 57

**artboards**, 12, 13
- aligning, 46, 150
- appearance changes, 44–45
- arranging, 42–43
- browsing on devices, 279
- changing multiple, 45
- creating, 38–41
- deleting, 39
- distributing, 150
- dragging, 43
- duplicating, 43–44
- editing, 41–44
- grids added to, 47–53, 57
- linking, 238–239
- managing with Layers panel, 53–56
navigating, 25–27
orientation options, 41
renaming, 27, 40
reordering, 133, 134, 159
resizing, 42, 57
responsive resize for, 46, 223
Retina (HiDPI) sizing for, 36
review questions/answers on, 57
screens represented as, 35
selecting, 42, 44, 45
artwork
adding from Illustrator, 79–80
aligning to pixel grid, 77–78
copying and pasting, 89
decomposing, 87
edges, 76
editing with Pen tool, 88–89
masking images or, 111–117
symbols created from, 170–171
zooming in/out of, 20, 21–24, 31
assets
CC Library, 187–194
exporting, 323–333
importing, 97–101
managing, 163–186
naming/renaming, 326, 341
Assets panel, 12, 13, 163–186
character styles in, 166–169
custom colors in, 163–166
gradient colors viewed in, 201
opening and closing, 17, 163
symbols in, 170–186
types of assets in, 163, 195
audio recording, 272
auto-animating content, 247–249, 267
auto-correct feature, 118, 126
Autosave feature, 36
Available Offline option, 284

B
backgrounds
blur effect for, 205–206, 231
color for artboard, 44, 45
bitmap images, 61
blur effects
background blur, 205–206
object blur, 206–207
Boolean operations, 74
borders
options for, 68–69
shape, 64–65
Bring Forward command, 131
Bring to Front command, 131
Browse Artboards option, 279, 282

C
character styles, 166–169
CC Library, 190–191
deleting, 169
editing, 169, 195
saving, 166–168
circles
creating, 63, 68, 74
duplicating, 70
image fills in, 115–117
Classroom in a Book training series, 1
closed paths, 83
cloud documents
described, 36, 285
previewing on devices, 281–284
saving XD documents as, 281
sharing, 289–292
video on working with, 37
code, embed, 297
Color Picker, 45, 64, 65, 66, 199
color stops, 199, 200, 203

datisnetwork.com
color swatches
deleting, 65, 165
editing, 165–166
colors
background, 44, 45
border, 65
fill, 64
gradient, 202–203
saving, 163–165
Column Width values, 52
combining shapes, 74–76, 93
comment icon, 301, 305
comments, 300–308, 319
   adding, 300–302
guest, 302
   notification of, 308
   pinning, 303–304
   working with, 305–308
Comments panel, 301, 302, 303, 304, 305
connections
copying and pasting, 244–246
   connections, 244–246
   embed code, 297
   Photoshop files, 106–107
   replacement images, 102
   selected artwork, 89
   shared prototype links, 300
   symbol instances, 174
   from UI kits, 91–92
corner points, 75, 84, 93
corner widgets, 70, 71, 103
Creative Cloud
cloud documents stored in, 36
   previewing documents loaded from, 275, 281–284
   saving XD documents to, 281
shared prototypes stored in, 319
   working with documents from, 37
Creative Cloud Libraries, 187–194, 195
   character styles used from, 190–191
   editing items in, 193–194
   graphics used from, 191–193
   Illustrator assets added to, 189–190
   Photoshop assets added to, 187–189
   selecting multiple objects in, 192
curves, drawing, 83–85, 93
Custom Size icon, 35
D
dash values, 67
dashed lines, 66–67
deleting
   artboards, 39
   character styles, 169
   color swatches, 65, 165
   comments, 306
downloaded XD files, 280
   See also removing
Design mode, 14–18
datisnetwork.com
panels, 16–18
Property Inspector, 15
toggling Prototype mode and, 19, 236
tools used in, 14
design specs, 308–317
inspecting, 312–316
sharing, 308–312
updating, 317
viewing, 312, 315
designs
finishing, 338–340
previewing, 28–29
sharing, 29, 31
workflow for UX, 9–10
Desktop Preview, 28, 240
destination setting, 239
development, sharing for, 289, 310–312, 317
Device Preview option, 277
device previews, 275–284
cloud documents for, 281–284
deleting files from, 280
mobile app setup for, 275–276
USB connection for, 276–280, 285
direction handles, 83
direction lines
creating, 83–84
splitting, 86
direction points, 83
distances
setting between gaps, 152–154
viewing with temporary guides, 155
distributing
artboards, 150
objects, 148–150
documents
cloud, 36
creating, 35–37
panning, 24–25
saving, 37
switching between, 30
zooming in/out of, 20, 21–24, 31
downloading
lesson files, 3
UI kits, 90–91
drag triggers, 249–250
dragging
artboards, 43
images, 100–101, 110
drawing
curves, 83–85, 93
grid used for, 83
straight lines, 81–82, 93
drop shadow effect, 208–209
duplicating
artboards, 43–44
lines, 77
shapes, 70
text, 124–126
duration setting, 239, 244, 250

E
easing transitions, 239
editing
artboards, 41–44
artwork, 88–89
CC Library items, 193–194
character styles, 169, 195
color swatches, 165–166
comments, 306
connections, 241–244
gradient colors, 202–203
group content, 143–144
masks, 112–114, 116–117
repeat grids, 213–217
shapes, 72–74, 76–77, 88–89
symbols, 171–173
educator resources, 5
effects, 205–209

datisnetwork.com
effects (continued)
  background blur, 205–206
  drop shadow, 208–209
  object blur, 206–207
Ellipse tool, 63, 68, 74, 115
embedding shared prototypes, 297, 319
Export For option, 310, 311, 328, 332
exporting assets, 323–333, 341
  to After Effects, 333
  batch export for, 333
  file formats for, 323, 341
  as JPG files, 332–333
  as PDF files, 324–325
  as PNG files, 327–331, 341
  as SVF files, 80, 325–327
eye icon, 139
Eyedropper tool, 64, 169

F
file formats
  for exporting assets, 323, 341
  supported for images, 96, 127
fills
  artboard, 44
  gradient, 199–204
  image, 115–117
  shape, 64
filtering options
  Comments panel, 307
  Layers panel, 139–141
Fix Height option, 225
Fix Width option, 225, 226, 227
fixed positioning, 156–158, 159
flipping
  lines, 77–78
  shapes, 73
folder icon, 108
Font menu, 122
fonts
  formatting, 122, 123–124
  missing, 11, 60, 163, 187, 189
mobile previews and, 277, 278
  used in lesson files, 4
footer symbols, 186
formatting text, 122–124, 166–169
forums, Adobe, 5
frames
  resizing images within, 104–105
  support for inline, 297
fullscreen mode, 295

G
Game Bar app, 272, 273–274
gaps
  changing in dashed lines, 67
  setting between objects, 152–154
gradient editor, 199, 200
gradient slider, 200, 202, 203, 204
gradients, 199–204
  applying, 199–202, 231
  description of, 199
  direction and length adjustments, 203–204
  editing colors of, 202–203
  linear and radial, 199
grammar check, 126
graphics
  types in Adobe XD, 61
  using from CC Libraries, 191–193
  See also raster images; vector graphics
Grid View button, 165, 184
grids, 47–53, 57
  drawing with, 83
  layout, 47, 51–53
  pixel, 77–78
  square, 47, 48–51
  See also repeat grids
groups, 141–144
  creating, 141–142, 224–225
  editing content within, 143–144, 159

datisnetwork.com
guest commenting, 302

guides
alignment, 62, 82, 151
temporary, 151, 155
Gutter Width values, 52

H
Hand tool, 24–25, 83, 119, 313
Helvetica Neue font, 4, 118, 122, 168, 187
Hex values, 44, 45, 169, 314
hiding/showing
content on artboards, 139
group content, 142
square grids, 63, 68
HiDPI (Retina) sizing, 36, 328
Highlight On Canvas command, 184
Home screen, 11, 35, 237, 267
hotspot hints, 278
HSB color values, 45, 132, 200, 202

I
Illustrator
adding assets to CC Libraries from, 189–190
bringing in content from, 79–80
exporting artwork from, 80
image icon, 109, 134
images, 96–117
adding from Photoshop, 106–110
copying and pasting, 102, 106–107
dragging and dropping, 102–104
filling shapes with, 115–117
formats supported for, 96, 127
importing, 97–101
masking, 111–117
opening from Sketch, 110
ordering in repeat grids, 215
positioning, 103
replacing, 101–102, 127, 215
rotating, 103–104
sizing/resizing, 97, 98, 103, 104–105
transforming, 102–104
using from CC Libraries, 191–192
importing
drag and drop for, 100–101
images into Adobe XD, 97–101
multiple assets, 99–100
objects with gradients, 199
text, 121
inspecting design specs, 312–316
installing
Adobe XD, 2
plugins, 334–335
instances, symbol, 171, 174, 195
interactivity
example of prototyping, 10
previewing prototypes with, 278
recording in prototypes, 271–274, 285
iOS
exporting PNG files for, 331
measurement units for, 310
resolution settings for, 311

J
JPG (JPEG) format
described, 323
exporting files as, 332–333, 341
importing images in, 97
jumpstart method, 4

L
language options, 262
Layers panel, 12, 13, 133–141
grouping objects using, 142
icons indicating object type in, 134
locking and hiding content from, 138–139
managing artboards with, 53–56, 57, 134

datisnetwork.com
Layers panel (continued)
  opening and working in, 16–17, 26–27
  reordering content in, 133–134
  searching and filtering in, 139–141
  selecting content using, 135–137
toggling the visibility of, 53

layout grids
  applying, 51–53
  explained, 47
  outline style, 53

Learn & Support page, 5, 30
lessons in book
  downloading files for, 3
  jumpstart method for, 4

libraries. See Creative Cloud Libraries
Libraries panel (Photoshop CC), 188
Line Spacing option, 122
Line tool, 66, 69, 77
linear gradients, 199
lines
  creating, 66–67, 69
curved, 83–85
dashes added to, 67
drawing, 81–85, 93
duplicating, 77
flipping, 77–78
straight, 81–82, 93
linked symbols, 176–183
  breaking links to, 173–175, 181
  creating, 176–178
  explained, 176
  fixing missing, 182–183
  overriding, 180
  updating, 178–180
links
  editing, 241–244
  managing, 318
  previewing, 240–241
  sharing prototype, 300
  See also connections
List View button, 171
Live Preview option, 276, 285
local symbols, 176, 183
Lock Aspect option, 41, 98, 103, 115, 117, 146
locking content, 137–138
low-fidelity wireframes, 10, 31

M
macOS
  native zooming, 20
  prototype recording, 271–272
  system requirements, 2
  workspace, 12
Manage Links command, 318
mask with shape command, 112
masks, 111–117, 127
  editing, 112–114, 116–117
  image fill, 115–117
  removing from content, 114
  shape or path, 111–112
Maximize application option, 11
measurement units, 49, 310
menu bar, 12
mobile app for Adobe XD, 275–276
mobile device previews, 275–284
  cloud documents for, 281–284
  deleting files from, 280
  mobile app setup for, 275–276
  USB connection for, 276–280, 285
modes
  Design mode, 14–18, 236
  Prototype mode, 18–20, 236
MP4 file format, 271, 285

N
naming/renaming
  artboards, 27, 40
  assets, 326, 341
  groups, 142

datisnetwork.com
navigating artboards, 25–27
New Library from Document dialog box, 188
notifications, comment, 308

O
object blur effect, 206–207, 231
objects
aligning to artboard, 144
aligning to each other, 147–148
arranging, 131–132
distributing, 148–150
grouping, 141–144
locking, 137–138
positioning, 151–158
saving as symbols, 170–171
setup to align, 144–147
offline documents, 283–284
on-canvas gradient editor, 200, 203, 204
Open in Browser icon, 294, 295
open paths, 83
ordering/reordering
artboards, 133, 134, 159
images in repeat grids, 215
layer content, 133–134
organizing content, 128–159
aligning objects and, 144–148
arranging objects and, 131–132
distributing objects and, 148–150
groups created for, 141–144
Layers panel for, 133–141
positioning objects and, 151–158
review questions/answers on, 159
orientation, artboard, 41
Outer Stroke button, 68
outline style, 53
overlays, 259–262
creating, 261–262
setting up content for, 259–260
video examples of, 262
overriding linked symbols, 180

P
panels
overview of main, 16–17
tip on displaying, 18
See also Assets panel; Layers panel
panning documents, 20, 24–25, 313
Paste Appearance option, 110
pasteboard, 12, 13, 136, 159
pasting. See copying and pasting
Path Edit mode, 72, 75, 88–89, 93, 113
paths
components of, 83
curved, 83–85
direction changes, 86–87
masking with, 111–112
reshaping text as, 119
straight, 81–82
PDF format
described, 323
exporting as, 324–325
Pen tool, 81–89, 93
curves drawn with, 83–85
editing artwork with, 88–89
lines drawn with, 81–82
path direction changes and, 86–87
Photoshop
adding assets to CC Libraries from, 187–189
bringing in content from, 106–110, 127
copying and pasting from, 106–107
opening files from, 108–110
Pin icon, 303, 304, 305
pinned comments, 303–304, 319
pixel grid, 77–78
pixels, virtual, 47
Plugin Manager, 334


datisnetwork.com
plugins, 334–340
  creating, 336
  explained, 334, 341
  installing, 334–335
  using, 336–338
PNG format
  described, 323
  exporting as, 327–331, 341
point text, 118–119, 127
positioning objects, 151–158
  aligning with temporary guides, 151
  fixed positioning for, 156–158, 159
  setting gap distances and, 152–154
  viewing distances and, 155
Preview window, 28–29, 240–241
previewing
  connections, 240–241
  designs, 28–29, 31
  prototypes, 275–284, 285
Property Inspector, 12, 13, 15
Prototype mode, 18–20, 236
prototypes, 232–285
  auto-animating content in, 247–249
  copying/pasting connections in, 244–246
  drag triggers added to, 249–250
  editing connections in, 241–244
  home screen setup for, 237
  interactivity in, 10, 238
  linking artboards in, 238–239
  mode for creating, 18–20, 236
  overlays used in, 259–262
  preserving scroll position in, 251–254
  previewing on a device, 275–284, 285
  purpose of using, 10, 31, 235
  recording, 271–274, 285
  review questions/answers on, 267, 285
  sharing for review, 293–308
  speech playback added to, 265–266
  testing connections in, 240–241
  timed transitions in, 255–258
  voice triggers added to, 262–264
  Push Overrides command, 172, 179

Q
  Quality setting, 332, 341

R
  radial gradients, 199
  radius, corner, 70, 71
  raster images
    sizing for Adobe XD, 97
    using from CC Libraries, 191
    vector graphics vs., 61
  See also images
  record button, 264, 265
  recording prototypes, 271–274, 285
    on macOS, 271–272
    on Windows, 272–274
  Rectangle tool, 62, 70, 72, 111, 131
  rectangles
    creating, 62, 72
    masking with, 111–112
    rounding corners of, 69–71
  removing
    masks from content, 114
    text from text area, 121
  See also deleting
  renaming. See naming/renaming
  reordering. See ordering/reordering
  repeat grids, 210–221
    adding content to, 217–219, 231
    creating, 211–213
    description of, 210, 231
    editing content in, 213–216
    finishing touches for, 219–221
    modifying appearance of, 217
    ordering images in, 215
    replacing images in, 215, 231
    selecting content for, 210–211

datisnetwork.com
setting up text files for, 216
sizing/resizing, 212
ungrouping, 219
replacing
images, 101–102, 127, 215
symbols, 183–185
replying to comments, 306
resizing. See responsive resize; sizing/resizing
resolution settings, 311
resolved comments, 307, 319
resources for Adobe XD, 5, 30
responsive resize, 222–230
artboards and, 46, 223
description of, 222
finishing designs after, 229–230
getting started with, 222–223
grouping content for, 224–225
manual constraints for, 225–228
Retina (HiDPI) sizing, 36, 328
review, sharing for, 289, 293–295, 297, 299, 300, 301
rotating
devices, 278
images, 103–104
shapes, 73
text, 118
Round Cap button, 67, 69, 78
rounded-corner rectangles, 69–71

S
San Francisco fonts, 4, 90–91
saving
character styles, 166–168
colors, 163–165
documents, 37
symbols, 170–171
scaling images, 98, 103
screens
device size options for, 35
See also artboards
scroll position preservation, 239, 251–254
content setup for, 251–252
steps in process of, 251–254
searching
in Layers panel, 139–141
in Plugin Manager, 334
Select tool, 14, 38, 42, 44, 45, 48
selecting
artboards using Select tool, 42, 44, 45
content using Layers panel, 135–137
multiple objects in CC Libraries, 192
Send Backward command, 131, 132
shadows, drop, 208–209
shapes, 61–78
borders for, 64–65
combining, 74–76, 93
creating, 62–63, 72
duplicating, 70
editing, 72–74, 76–77, 88–89
fills for, 64, 115–117
flipping, 73
masking with, 111–112
rotating, 73
Share Document option, 289, 290, 291, 319
Share for Development window, 310–312, 317
Share For Review window, 293–295, 297, 299, 300, 301
shared prototypes, 293–308
commenting on, 300–302, 319
copying links to, 300
embedding in web pages, 297
file storage for, 319
pinning comments in, 303–304
steps for creating, 293–296
updating, 297–300
sharing, 19, 286–319
cloud documents, 289–292
design specs, 308–312
datisnetwork.com
sharing (continued)
managing links for, 318
overview on methods of, 289
prototypes for review, 293–308
review questions/answers on, 319
sizing/resizing
artboards, 42, 57, 223
images, 97, 98, 103, 104–105
repeat grids, 212
See also responsive resize
Sketch, adding assets from, 110
Smart Objects, 188
smooth points, 84, 87, 93
snapping, disabling, 103, 127
speech detection, 262
speech playback, 262, 265–266
spelling check, 126
square grids
drawing with, 83
explained, 47
hiding/showing, 63, 68
shape creation and, 72
working with, 48–51
stacking order, 131, 159
straight lines, 81–82, 93
styles, text/character, 122–124, 166–169
Subtract option, 75–76
SVG format
described, 323
exporting as, 325–327
swatches. See color swatches
Swatches button, 194
symbols, 170–186
breaking links to, 173–175, 181
copying instances of, 174
creating, 170–171, 195
defined, 163, 170
editing, 171–173
footer groups as, 186
linked, 176–183
local, 176, 183
replacing, 183–185
responsive resize and, 223, 226–227
system requirements, 2
T
tap triggers, 239, 244, 248
temporary guides
aligning with, 151
viewing distances with, 155
text, 118–126
area, 118, 119–120, 127
converting, 119
duplicating, 124–126
importing, 121
point, 118–119, 127
removing, 121
rotating, 118
spelling/grammar check, 126
styling, 122–124, 166–169
Text tool, 118, 119, 120, 167, 172
third-party integration, 340
time triggers, 255–258, 267
timed transitions, 255–258
content setup, 255–256
steps in setting, 256–258
toolbar, 12, 13
tools
Design mode, 14
Prototype mode, 19
transforming images, 102–104
transitions, 239, 255–258
triggers, 239, 267
drag, 249–250
tap, 239, 244, 248
time, 255–258
voice, 262–264
U
UI Faces plugin, 334, 336, 337
UI kits, 90–92, 93
copying/pasting from, 91–92
downloading, 90–91
opening files in, 91
undo command, 82, 172, 226
Ungroup Grid button, 219
Ungroup Mask option, 114
units of measurement, 49, 310
updating
cloud documents, 284
design specs, 317
linked symbols, 178–180
shared prototypes, 297–300
USB-connected previews, 275, 276–280, 285
user experience (UX) design workflow, 9–10

V
vector graphics
adding from Illustrator, 79–80
raster images vs., 61
using from CC Libraries, 191, 192–193
working with shapes as, 61–78
video recording prototypes, 271–274
video tutorials/examples
animating the record button, 265
auto-animating content, 249
batch exporting assets, 333
cloud documents, 37
exporting artwork from Illustrator, 80
overlays, 262
view commands, 21–22
viewing
design specs, 312, 315
distances, 155
distances, 155
virtual pixels, 47
voice triggers, 262–264

W
Web Edition of book, 3
web pages
embedding shared prototypes in, 297, 319
measurement units for, 310
resolution settings for, 311
widgets, corner, 70, 71, 103
Windows
native zooming, 20
prototype recording, 272–274
system requirements, 2
workspace, 13
wireframes, low-fidelity, 10, 31
workflow, UX design, 9–10
workspaces
macOS, 12
Windows, 13

X
XD program. See Adobe XD
XDX file format, 334

Z
Zoom tool, 22–24, 67, 77
zooming in/out, 20, 21–24, 31, 66, 313